Sage direct : Changer les certificats clients
Description

Au lancement de Sage direct, un mois avant l'expiration des certificats, un message d'information apparaît :

                               

Ce message apparait si l'option, dans Outils/ Options/ Transferts bancaires, "Me notifier en cas de péremption prochaine de mes certificats bancaires" est cochée.

Vous avez la possibilité d’effectuer le renouvellement manuellement (en cliquant sur NON) ou à l’aide d’un assistant (en cliquant sur OUI).

Cause

Les 3 certificats nécessaires pour les transferts bancaires via Sage direct ont une durée de validité qui couvre généralement une période de 5 ans. Cela varie cependant selon les fournisseurs et les types de certificats.

Avant cette échéance, il est nécessaire de remplacer les certificats par de nouveaux générés. Dans le cas contraire, lors de la communication avec la banque, une erreur va apparaître indiquant que les certificats ont expiré.

Resolution

Retrouver ci-dessous les différentes procédures lors d'un changement de certificats depuis Sage Direct :

 REMARQUE: Si vous êtes dans le cas d'un changement de certificats sur une banque NON initialisée en mode Ebics T et TS, nous vous conseillons de procéder à une suppression de votre banque, et de recréer cette dernière avec les nouveaux certificats. Si votre banque n'a jamais été initialisée, cela signifie qu'elle n'a jamais été active.

Informations complémentaires

La fonction ‘Révoquer les certificats’ ne doit jamais être utilisée dans le cas de changement des certificats. Si la banque est toujours initialisée (Verte/Statut HPB), seule la fonction ‘Renouveler avec ces certificats’ doit être utilisée comme décrit dans le paragraphe 2) et 3). Si toutefois, cette fonction a été activée par erreur, il sera nécessaire de refaire l’initialisation comme indiqué dans le paragraphe ‘Rappel de la procédure de première initialisation’ du point 5).

Lors du changement des certificats, les requêtes envoyées à la banque dépendent des certificats qui ont été modifiés :

  • Changement des certificats ‘Authentification’ et ‘Chiffrement’ : Requête HCA
  • Changement du certificat ‘Signature’ : Requête PUB
  • Changement des trois certificats ‘Authentification’, ‘Chiffrement’ et ‘Signature’ : Requête HCS
Steps to duplicate
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