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Résoudre l'erreur : Impossible d'enregistrer un nouvel environnement utilisateur, la limite maximale a été atteinte

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Summary

Cet article explique pourquoi un message d'enregistrement d'un nouvel utilisateur empêche de se connecter sur Sage PE et Batigest Connect.

Description

Lors de la tentative de connexion, le message suivant s'affiche :
"Impossible d'enregistrer un nouvel environnement utilisateur, la limite maximale a été atteinte".

Ce message empêche d'accéder au dossier concerné avec l'utilisateur sélectionné.
Ce message n'est pas bloquant et n'apparaît pas pour un utilisateur qui s'est déjà connecté.

Les environnements utilisateurs sont sauvegardés dans un fichier nommé Batig.ini.txt. Ce fichier contient également divers paramètres liés à l'utilisateur, comme les polices d'écriture et les configurations de listes.
Ce fichier identifie les environnements utilisateurs par leur code utilisateur. Chaque code correspond ainsi à un emplacement utilisateur distinct.

Si le message apparaît, il est nécessaire de répertorier les utilisateurs présents dans chaque dossier Batigest Connect. Ensuite, il est nécessaire de supprimer les utilisateurs qui ne sont pas utilisés.
 MISE EN GARDE : Il est crucial de sauvegarder le fichier Batig.ini.txt avant toute manipulation. Comme ce fichier n'est pas inclus dans la sauvegarde du dossier société, il faudra en faire une copie manuelle. 

Cause

Ce message indique que le nombre total d'environnements utilisateurs, tout dossier confondu, est trop important pour l'application.

Resolution

  1. Ouvrez la liste des utilisateurs dans chaque dossier société pour répertorier chaque utilisateur.
    Notez ensuite les codes utilisateurs correspondants. 
  2. Repérez les codes utilisateurs qui ne sont plus utilisés dans aucun des dossiers sociétés.
  3. Ouvrez ensuite le Batig.ini.txt
  4. Sur la section [Reseau] :
    1. Supprimez le ou les codes utilisateurs non utilisés.  MISE EN GARDE : ne pas supprimer le numéro d'ordre ou de poste (Cf. l'exemple ci-dessous) 
       REMARQUE : Si certains codes utilisateurs figurent dans le fichier Batig.ini.txt mais sont absents des dossiers société (et donc de la liste précédemment établie), supprimez-les également.
       EXEMPLE : Suppression des informations des utilisateurs PAGRT et 00000002. 

      Avant : Après :
      [Réseau]
      00=SYS_ADM
      01=PAGRT
      02=ANOIO
      03=00000002
      04=00000004
      [Réseau]
      00=SYS_ADM
      01=
      02=ANOIO
      03=
      04=00000004

       MISE EN GARDE : Veillez à ne pas ajouter de saut de ligne.
    2. Dans la suite du fichier. Il y a des informations inhérentes aux numéros de poste sous la forme [Poste : XX] (XX étant le numéro). Supprimez toute cette section.
       EXEMPLE : Suppression de la section [Poste : 01] 

      [Poste : 01]
      TypeFond=0
      DerSoc=-SOC01
      Etat Listes=0
      TriListe=G
      Devis:Couleur Texte Tranche niveau 1=9527094
      Devis:Couleur Fond Tranche niveau 1=16777215
      Devis:Police Tranche niveau1=Type:T/Niveau:1/Name:Arial/Italic:Vrai/Italic:Faux/Bold:Vrai/Size:12/Charset:0 /Strikethrough:Faux/Underline:Vrai/
      [...]

       MISE EN GARDE : Ne supprimez pas d'autre section 
  5. Enregistrez le fichier.
  6. Ouvrez chaque dossier pour supprimer les utilisateurs non utilisés.