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INTERNE : Erreur : "Étiquette inexistante"

Created on  | Last modified on 

Summary

Cet article indique comment résoudre ce message rencontré sur Sage X3.

Description

Sur Sage X3, il est possible de rencontrer le message suivant : 

"Etiquette existante"

 

Mise à jour 10/04/2018 (no english version)

Cause

Il est possible que le bogue provoquant ce message d'erreur résulte de l'une des deux causes suivantes. 

Resolution

Étiquette ACTION

Le premier message d'erreur est :

ACTION : Etiquette inexistante

suivi d'un second message de la forme :

@NOM-DE-DOSSIER.TRT/GOBJSUB$adx(NUMERO-DE-LIGNE) : Gosub ACTION From =NOM-DE-VARIABLE

Pour corriger ce bogue, ajoutez une étiquette ACTION dans le traitement indiqué par la variable NOM-DE-VARIABLE.

Pour trouver la valeur de cette variable, reproduisez le bogue sous la supervision du débogueur.

▼ Pour lancer le débogeur

Pour lancer ce dernier :

  1. Cliquez sur ? dans la barre de menu.
  2. Cliquez sur Aide au diagnostic > Debugger.
  3. Répétez la manipulation qui a provoqué le message d'erreur. La fenêtre du débogueur s'affiche.
  4. Dans le bloc Points d'arrêts, saisissez dans la première ligne du tableau :
    GOBJSUB:NUMERO-DE-LIGNENUMERO-DE-LIGNE est le nombre indiqué dans le second message d'erreur.
  5. Cliquez sur le bouton Continuer.
  6. Le bloc Source s'actualise. Vérifiez que le titre de la seconde colonne se termine par GOBJSUB.adx. Vérifiez aussi qu'un X s'affiche dans la première colonne à la ligne NUMERO-DE-LIGNE.
  7. Si ce n'est pas le cas, cliquez sur le bouton Continuer jusqu'à ce que cela se produise.
  8. Dans le bloc Variables, saisissez dans la colonne Expression :
    NOM-DE-VARIABLENOM-DE-VARIABLE est le dernier mot du second message d'erreur.
  9. La valeur de la variable apparaît dans la colonne Valeur.
  10. Appuyez sur Fin pour quitter le débogueur.

 

La valeur trouvée est un nom de traitement auquel il manque l'étiquette : 

  1. Lancez la fonction Développement > Dictionnaire de traitements > Éditeur de traitements.
  2. Dans la boîte de dialogue, zone Nom du fichier, saisissez la valeur trouvée.
  3. Vérifiez que la zone Application corresponde au NOM-DE-DOSSIER du second message d'erreur.
  4. Cliquez sur Ouvrir.
  5. Dans l'éditeur de texte, insérez tout au début les deux lignes suivantes :
    $ACTION
    Return
  6. Compilez le traitement en appuyant sur la touche F7 du clavier.
  7. Le bogue est corrigé.

Souvent, le traitement impliqué est le traitement spécifique principal lié à la fonction utilisée. Celui-ci existe mais sans l'étiquette ACTION.

Exemple : une erreur à l'entrée dans les articles, fonction GESITM, le traitement à contrôler au préalable est SPEITM.

Autre étiquette

Le premier message d'erreur est de la forme :

NOM-D'ETIQUETTE : Etiquette inexistante

suivi d'un second message de la forme :

@NOM-DE-DOSSIER.TRT/NOM-DE-TRAITEMENT-1$adx(NUMERO-DE-LIGNE) : Gosub NOM-D'ETIQUETTE From NOM-DE-TRAITEMENT-2

Ou de la forme :

@NOM-DE-DOSSIER.TRT/NOM-DE-TRAITEMENT-1$adx(NUMERO-DE-LIGNE) : Call NOM-D'ETIQUETTE(LISTE-DE-PARAMETRES-SEPARES-PAR-DES-VIRGULES) From NOM-DE-TRAITEMENT-2

Il est possible de corriger ce bogue par les opérations ci-dessous. Seulement lorsque le traitement NOM-DE-TRAITEMENT-2 est à la fois dans le dossier courant et dans le dossier X3.

Il suffit alors de le supprimer du dossier courant qui pour une raison indéterminée en contient une version périmée.

 REMARQUE: Si ce traitement est un traitement spécifique, c'est-à-dire qu'il commence par les lettres X, Y, Z ou SPE, alors il faudra se tourner vers son auteur. Car démarche ci-dessous aura très peu de chance de corriger le bogue. 

  1. Allez dans la fonction Développement > Dictionnaire de traitements > Dictionnaire de traitements.
  2. Rendez-vous sur la fiche de code NOM-DE-TRAITEMENT-2 où NOM-DE-TRAITEMENT-2 est le dernier mot du second message d'erreur.
  3. Lisez le dernier bloc qui contient des commentaires en italique sur fond gris.
  4. Si le texte en italique Traitement est existant dans l'archive du dossier X3 alors il s'agit d'un bogue plus complexe. Transmettez-le au support Sage.
  5. Si le texte en italique Traitement existant dans l'archive du dossier NOM-DE-DOSSIER où NOM-DE-DOSSIER est le premier mot du second message d'erreur, allez dans la fonction : 
    Développement > Utilitaires > Dictionnaire > Archive traitement.
  6. Dans le bloc Opération sur l'archive, sélectionnez Suppression.
  7. Vérifiez que la zone Dossier est le dossier NOM-DE-DOSSIER. Vérifiez aussi que dans la zone suivante la valeur Serveur est sélectionnée.
  8. Dans la zone Traitement saisissez NOM-DE-TRAITEMENT-2.
  9. Cochez la case Source pour éviter que le bogue ne se reproduise à la prochaine génération de l'archive.
  10. Appuyez sur OK et vérifiez que le bogue soit corrigé, sinon contactez le support Sage.

 ATTENTION: Avant de faire cette suppression, sauvegardez par sécurité les fichiers archive.atx et atx.ind du répertoire du dossier mis à jour.